Каталог решений для 1С. Скачать

Бесплатные курсы по 1С
Бесплатные материалы по 1С:Бухгалтерии предприятия 2.0 и 3.0
Обработка в каталоге
Интерактивная ОСВ 3
Обработка на сайте

Автоматическое заполнение реквизитов контрагента по ИНН

В связи с изменениями на сайте "Контур-фокус" мы были вынуждены исправить нашу обработку. Сейчас она проходит бета-тест. Ориентировочный срок выхода новой версии - 20.09.2015.

Уважаемый Пользователь 1С!

В нашей коллекции есть очень много решений типовых вопросов и задач по 1С, которые мы можем отдать Вам бесплатно.

Вы можете зарегистриро-ваться у нас на сайте и обратиться к нам со своими вопросами, и если ответ на него или решение у нас уже готово, мы можем с радостью подарить его Вам или отдать за символическую плату.

Как вызвать функцию 1С из JavaScript для обычных и управляемых форм

Это статья для Специалистов по 1С.

Иногда к нам обращаются с вопросом по поводу того, как из JavaScript’а в ПолеHTMLДокумента вызвать функцию 1С.

В этой статье мы приведем сразу 2 примера:

  • вызов функции JavaScript в ПолеHTMLДокумента из 1С
  • вызов функции 1С из JavaScript в ПолеHTMLДокумента

В первом случае функция вызывается достаточно просто:

ЭтаФорма.Элементы.хНТМЛ.Документ.parentWindow.MyFunction ();

Второй случай чуть сложнее. Суть его реализации заключается в следующем:

  1. Объявить экспортную функцию в форме (с ключевым словом Экспорт).
  2. Передать ссылку на форму (обычную или управляемую) в переменную JavaScript.
  3. В нужный момент вызвать из JavaScript нашу экспортную функцию как обычный метод формы.

Дальше приведен код для управляемой формы, а для обычной формы код выглядит аналогично.

&НаКлиенте
Функция СобытиеНТМЛ (Параметр1) Экспорт
    Сообщить (Параметр1);
КонецФункции

&НаКлиенте
Процедура ПриОткрытии(Отказ)
хНТМЛ = «<html>
|<head>
|<script>
| var xForm1C;
|function SetForm1C (Form1C)
|{
|  xForm1C = Form1C;
|}
|
|function Call1C (param1)
|{
|   xForm1C.СобытиеНТМЛ (param1);
|}
|
|</script>
|</head>
|
|<body>Тест вызова функции 1С из JS</br /><br />
|<input id=’param1′ type=’text’ value=’Параметр1′ /><br />
|<input type=’button’ onclick=’Call1C(param1.value)’ value=’Вызов функции в 1С’ />
|
|</body>
|</html>»;
КонецПроцедуры

// передаем ссылку на форму в HTML документ после того, как он будет сформирован
&НаКлиенте
Процедура хНТМЛДокументСформирован(Элемент)
ЭтаФорма.Элементы.хНТМЛ.Документ.parentWindow.SetForm1C (ЭтаФорма);
КонецПроцедуры

Скачать текст кода можно здесь.

Поделиться в соц. сетях

Опубликовать в Google Buzz
Опубликовать в Google Plus
Опубликовать в LiveJournal
Опубликовать в Мой Мир
Опубликовать в Одноклассники

Оставить комментарий

Вы должны авторизоваться для отправки комментария.

Каталог решений для 1С. Скачать

Введите адрес электронной почты:

Delivered by FeedBurner

Яндекс.Метрика