Каталог решений для 1С. Скачать

Бесплатные курсы по 1С
Бесплатные материалы по 1С:Бухгалтерии предприятия 2.0 и 3.0
Обработка в каталоге
Интерактивная ОСВ 3
Обработка на сайте

Автоматическое заполнение реквизитов контрагента по ИНН

В связи с изменениями на сайте "Контур-фокус" мы были вынуждены исправить нашу обработку. Сейчас она проходит бета-тест. Ориентировочный срок выхода новой версии - 20.09.2015.

Уважаемый Пользователь 1С!

В нашей коллекции есть очень много решений типовых вопросов и задач по 1С, которые мы можем отдать Вам бесплатно.

Вы можете зарегистриро-ваться у нас на сайте и обратиться к нам со своими вопросами, и если ответ на него или решение у нас уже готово, мы можем с радостью подарить его Вам или отдать за символическую плату.

Заметки программиста 1С: Работа с буфером обмена Windows из 1С

В этой заметке приведен программный код для работы с буфером обмена Windows.

Всем разработчикам 1С известно, что напрямую 1С с буером обмена Windows не работает, поэтому приходится использовать обходные пути. Одним из таких путей является создание на клиентской стороне COM-объекта «HTMLFile»,  и работа с буфером обмена идет через него. Код такого варианта работы здесь и приведен.

Для Обычного приложения:

Процедура ЗаписатьТекстВБуферОбмена (пСтрока)
#Если Клиент Тогда
хОбъект = Новый COMОбъект(«htmlfile»);
хОбъект.ParentWindow.ClipboardData.Setdata(«Text», пСтрока);
Возврат;
#КонецЕсли
КонецПроцедуры

Функция ПолучитьТекстИзБуфераОбмена ()
Результат = Неопределено;
#Если Клиент Тогда
хОбъект = Новый COMОбъект(«htmlfile»);
Результат = хОбъект.ParentWindow.ClipboardData.Getdata(«Text»);
#КонецЕсли
Возврат Результат;
КонецФункции

Для Управляемого приложения:

&НаКлиенте
Процедура ЗаписатьТекстВБуферОбмена (пСтрока)
хОбъект = Новый COMОбъект(«htmlfile»);
хОбъект.ParentWindow.ClipboardData.Setdata(«Text», пСтрока);
Возврат;
КонецПроцедуры

&НаКлиенте
Функция ПолучитьТекстИзБуфераОбмена ()
Результат = Неопределено;
хОбъект = Новый COMОбъект(«htmlfile»);
Результат = хОбъект.ParentWindow.ClipboardData.Getdata(«Text»);
Возврат Результат;
КонецФункции

Поделиться в соц. сетях

Опубликовать в Google Buzz
Опубликовать в Google Plus
Опубликовать в LiveJournal
Опубликовать в Мой Мир
Опубликовать в Одноклассники

Один комментарий на “Заметки программиста 1С: Работа с буфером обмена Windows из 1С”

Оставить комментарий

Вы должны авторизоваться для отправки комментария.

Каталог решений для 1С. Скачать

Введите адрес электронной почты:

Delivered by FeedBurner

Яндекс.Метрика