Каталог решений для 1С. Скачать

Бесплатные курсы по 1С
Бесплатные материалы по 1С:Бухгалтерии предприятия 2.0 и 3.0
Обработка в каталоге
Интерактивная ОСВ 3
Обработка на сайте

Автоматическое заполнение реквизитов контрагента по ИНН

В связи с изменениями на сайте "Контур-фокус" мы были вынуждены исправить нашу обработку. Сейчас она проходит бета-тест. Ориентировочный срок выхода новой версии - 20.09.2015.

Уважаемый Пользователь 1С!

В нашей коллекции есть очень много решений типовых вопросов и задач по 1С, которые мы можем отдать Вам бесплатно.

Вы можете зарегистриро-ваться у нас на сайте и обратиться к нам со своими вопросами, и если ответ на него или решение у нас уже готово, мы можем с радостью подарить его Вам или отдать за символическую плату.

Заметки программиста 1С: Как получить список принтеров в системе Windows

Мы продолжаем наш цикл статей «Заметки программиста 1С«. В этой статье приводится код, позволяющий получить список принтеров Windows. Через некоторое время мы соберем все подобные функции в файл шаблонов, который можно будет установить в Конфигураторе.

мсПринтеров = ПолучитьМассивПринтеров ();
Если мсПринтеров.Количество () > 0 Тогда
Сообщить («Порт: «+мсПринтеров [0].Порт);    // порт принтера
Сообщить («Имя принтера: «+мсПринтеров [0].Имя); // имя принтера
КонецЕсли;
//
Функция ПолучитьМассивПринтеров ()
хШелл = Новый COMОбъект(«WScript.Network»);
мсПринтеры = Новый Массив;
хПринтеры = хШелл.EnumPrinterConnections ();
Для Ц = 0 По (хПринтеры.length / 2) — 1 Цикл
ТекСтруктура = Новый Структура («Порт, Имя», );
ТекСтруктура.Порт = хПринтеры.Item (Ц);
ТекСтруктура.Имя = хПринтеры.Item (Ц + 1);
мсПринтеры.Добавить(ТекСтруктура);
КонецЦикла;
Возврат мсПринтеры;
КонецФункции

Поделиться в соц. сетях

Опубликовать в Google Buzz
Опубликовать в Google Plus
Опубликовать в LiveJournal
Опубликовать в Мой Мир
Опубликовать в Одноклассники

Оставить комментарий

Вы должны авторизоваться для отправки комментария.

Каталог решений для 1С. Скачать

Введите адрес электронной почты:

Delivered by FeedBurner

Яндекс.Метрика